StatusBarWidgetControl Class

Deprecated  in 4.16.0. Extends a deprecated class WidgetControl.

Status Bar Widget Control.

Extends

Extended by

Methods

Name Description
constructor(info: ConfigurableCreateInfo, options: any): StatusBarWidgetControl    
getReactNode(): React.ReactNode Abstract Gets the React node associated with this StatusBar Widget Control  
getType(): ConfigurableUiControlType Gets the type of ConfigurableUiControl, which is 'StatusBarWidget' in this case  

Inherited methods

Name Inherited from Description
onFrontstageDeactivated(): void Inherited WidgetControl Called when Frontstage is deactivated.
onFrontstageReady(): void Inherited WidgetControl Called when Frontstage is ready.
onInitialize(): void Inherited WidgetControl Called to initialize the ConfigurableUiControl.
onWidgetStateChanged(): void Inherited WidgetControl Called when widget state changes.
restoreTransientState(): boolean Inherited WidgetControl Overwrite to restore transient DOM state.
saveTransientState(): void Inherited WidgetControl Overwrite to save transient DOM state (i.e.
setWidgetState(state: WidgetState): void Inherited WidgetControl Sets the WidgetState for this control

Inherited properties

Name Type Inherited from Description
_appDataOptions Protected Inherited any WidgetControl  
applicationData Accessor Inherited ReadOnly any WidgetControl allow options set via appData to be seen by API calls
classId Accessor Inherited ReadOnly string WidgetControl Gets the class Id of configurable element
controlId Accessor Inherited ReadOnly string WidgetControl Returns the ID of this ConfigurableUiControl.
isReady Accessor Inherited ReadOnly Promise<void> WidgetControl Returns a promise that resolves when the control is ready for usage.
name Accessor Inherited ReadOnly string WidgetControl Get internal name of configurable element. If no name is defined in configuration
then the name will match the UniqueId.
reactNode Accessor Inherited React.ReactNode WidgetControl The ReactNode associated with this control
widgetDef Accessor Inherited WidgetDef WidgetControl The WidgetDef associated with this control

Defined in

Last Updated: 30 January, 2025