ToolWidgetComposerProps Interface
Deprecated in 4.17.0. Use React.ComponentProps<typeof ToolWidgetComposer>
Properties for the ToolWidgetComposer React components
Extends
Properties
Name | Type | Description | |
---|---|---|---|
cornerItem | React.ReactNode | undefined | Optional Corner Item which for most stages is the BackstageAppButton used to toggle the display of the backstage menu. | |
horizontalToolbar | React.ReactNode | undefined | Optional Horizontal Toolbar | |
verticalToolbar | React.ReactNode | undefined | Optional Vertical Toolbar |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.