StageContentLayout Class
StageContentLayout class. Used to serialize/deserialize a View Layout with Saved Views.
Methods
Name | Description | |
---|---|---|
constructor(): StageContentLayout | ||
emphasizeElementsFromProps(contentGroup: ContentGroup, savedProps: StageContentLayoutProps): boolean Static | Apply EmphasizeElements from the SavedView | |
viewLayoutToProps(contentLayoutDef: ContentLayoutDef, contentGroup: ContentGroup, emphasizeElements: booleanfalse, contentCallback?: ContentCallback): StageContentLayoutProps Static | Create props for a View Layout | |
viewStatesFromProps(iModelConnection: IModelConnection, savedProps: StageContentLayoutProps): Promise<undefined | ViewState[]> Static | Create an array of ViewStates from the StageContentLayout |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.