IModelViewportControl Class
Deprecated in 4.16.0. Use ($@itwin/imodel-components-react#ViewportComponent$refLinkSource=appui-react/ui/appui-react/src/appui-react/content/IModelViewport.tsx@103) component instead.
iModel Viewport Control
Extends
Methods
Name | Description | |
---|---|---|
constructor(info: ConfigurableCreateInfo, _options: IModelViewportControlOptions): IModelViewportControl | ||
_getViewOverlay(vp: ScreenViewport): React.ReactNode Protected | Get the default ViewOverlay unless parameter is set to not use it. | |
getImodelConnectedViewportReactElement(): React.ReactNode Protected | Get the React component that will contain the Viewport | |
getImodelViewportReactElement(iModelConnection: IModelConnection, viewState: ViewStateProp): React.ReactNode Protected | Get the React component that will contain the Viewport | |
getNoContentReactElement(_options: IModelViewportControlOptions): React.ReactNode Protected | Get the React component that will be shown when no iModel data is available | |
getReactElementForViewSelectorChange(iModelConnection: IModelConnection, _unusedViewDefinitionId: string, viewState: ViewState, _name: string): React.ReactNode | Get the React.Element for a ViewSelector change. | |
getReactNode(): React.ReactNode Protected | ||
initializeReactNode(): void Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getKeyedReactNode(): React.ReactNode Protected | ViewportContentControl | |
getType(): ConfigurableUiControlType | ViewportContentControl | Gets the type of ConfigurableUiControl, which is 'Viewport' in this case |
onActivated(): void | ViewportContentControl | Called when this ContentControl is activated |
onDeactivated(): void | ViewportContentControl | Called when this ContentControl is deactivated |
onFrontstageDeactivated(): void | ViewportContentControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void | ViewportContentControl | Called when Frontstage is ready. |
onInitialize(): void | ViewportContentControl | Called to initialize the ConfigurableUiControl. |
processViewSelectorChange(iModel: IModelConnection, viewDefinitionId: string, viewState: ViewState, name: string): Promise<void> | ViewportContentControl | Process a ViewSelector change. |
setIsReady(): void | ViewportContentControl | Returns a promise that resolves when the control is ready for usage. |
Properties
Name | Type | Description | |
---|---|---|---|
_alwaysUseSuppliedViewState Protected | boolean | ||
_featureOptions Protected | [key: string]: boolean | string | ||
_iModelConnection Protected | undefined | IModelConnection | ||
_options Protected | IModelViewportControlOptions | ||
_viewState Protected | undefined | ViewStateProp | ||
id Accessor Static ReadOnly | string | ||
navigationAidControl Accessor ReadOnly | string | Get the NavigationAidControl associated with this ContentControl |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected | any | ViewportContentControl | |
_reactNode Protected | React.ReactNode | ViewportContentControl | |
applicationData Accessor ReadOnly | any | ViewportContentControl | allow options set via appData to be seen by API calls |
classId Accessor ReadOnly | string | ViewportContentControl | Gets the class Id of configurable element |
controlId Accessor ReadOnly | string | ViewportContentControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor ReadOnly | Promise<void> | ViewportContentControl | Returns a promise that resolves when the control is ready for usage. |
isViewport Accessor ReadOnly | boolean | ViewportContentControl | Returns true if this control is a Viewport control. |
name Accessor ReadOnly | string | ViewportContentControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
reactNode Accessor | React.ReactNode | ViewportContentControl | The React node associated with this control. |
supportsViewSelectorChange Accessor ReadOnly | boolean | ViewportContentControl | Returns true if this control supports processing ViewSelector changes. |
viewport Accessor | undefined | ScreenViewport | ViewportContentControl | The underlying ScreenViewport |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.