BackstageComposerProps Interface

Deprecated  in 4.17.0. Use React.ComponentProps<typeof BackstageComposer>

Props of BackstageComposer component.

Extends

Properties

Name Type Description
header Readonly React.ReactNode | undefined React node for an optional header item  
hideSoloStageEntry Readonly boolean | undefined If true and only one stage launcher item is found, do not show entry in backstage  
items Readonly BackstageItem[] | undefined List of static backstage items to show.  
showOverlay Readonly boolean | undefined Indicates whether to place an overlay over the frontstage when the backstage is displayed  

Inherited properties

Name Type Inherited from Description
className string | undefined CommonProps Custom CSS class name
itemId string | undefined CommonProps Optional unique identifier for item.
style React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 20 November, 2024