AccuDrawFieldContainerProps Interface

Deprecated  in 4.17.0. Use React.ComponentProps<typeof AccuDrawFieldContainer>

Properties for AccuDrawFieldContainer component

Extends

Properties

Name Type Description
isBearingAngle boolean | undefined Indicates whether the field is displaying a bearing angles.  
orientation Orientation Orientation of the fields  
uiSettingsStorage UiStateStorage | undefined Optional parameter for persistent UI settings.  

Inherited properties

Name Type Inherited from Description
className Inherited string | undefined CommonProps Custom CSS class name
itemId Inherited string | undefined CommonProps Optional unique identifier for item.
style Inherited React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 30 January, 2025