UiFramework Class
Main entry point to configure and interact with the features provided by the AppUi-react package.
Methods
Name | Description | |
---|---|---|
constructor(): UiFramework | ||
closeCursorMenu(): void Static | ||
dispatchActionToStore(type: string, payload: any, immediateSync: booleanfalse): void Static | Deprecated | |
getAccudrawSnapMode(): SnapMode Static | Deprecated | |
getActiveIModelId(): string Static | Deprecated | |
getActiveSelectionScope(): string Static | Returns the stored active selection scope id. | Deprecated |
getAvailableSelectionScopes(): PresentationSelectionScope[] Static | Returns the stored list of available selection scopes. | Deprecated |
getColorTheme(): ThemeId Static | Set the theme value used by the ThemeManager component. | Deprecated |
getCursorMenuData(): undefined | CursorMenuData | CursorMenuPayload Static | ||
getDefaultIModelViewportControlId(): undefined | string Static | Deprecated | |
getDefaultViewId(): undefined | string Static | Deprecated | |
getDefaultViewState(): undefined | ViewState Static | ||
getIModelConnection(): undefined | IModelConnection Static | ||
getIsUiVisible(): boolean Static | Deprecated | |
getNumItemsSelected(): number Static | ||
getToolbarOpacity(): number Static | UiFramework.getToolbarOpacity() returns a number between 0 and 1 that is the non-hovered opacity for toolbars. | Deprecated |
getUiStateStorage(): UiStateStorage Static | The UI Settings Storage is a convenient wrapper around Local Storage to assist in caching state information across user sessions. | |
getWidgetOpacity(): number Static | Deprecated | |
hideCalculator(): boolean Static | Hides the calculator. | |
hideComponent(id?: string): boolean Static | Hides the Component previously shown with showComponent | |
hideKeyinPalette(): boolean Static | Hides the Key-in Palette. | |
hideMenuButton(id: string): boolean Static | Hides a menu button. | |
hideToolbar(): boolean Static | Hides a toolbar displayed via showToolbar | |
initialize(): Promise<void> Static | Called by the application to initialize the UiFramework. | |
initialize(store: Store<any, AnyAction>, frameworkStateKey?: string): Promise<void> Static | Called by the application to initialize the UiFramework. | Deprecated |
initializeStateFromUserSettingsProviders(immediateSync: booleanfalse): Promise<void> Static | Called by iModelApp to initialize saved UI state from registered UseSettingsProviders. | |
isMobile(): boolean Static | Deprecated | |
openContextMenu(items: CursorMenuItemProps[], location: Readonly<WritableXAndY>, anchorElement?: HTMLElement): boolean Static | Show a context menu at a particular location. | |
openCursorMenu(menuData: CursorMenuData | CursorMenuPayload): void Static | ||
registerUserSettingsProvider(entry: UserSettingsProvider): boolean Static | Registers class that will be informed when the UserSettingsStorage location has been set or changed. | |
setAccudrawSnapMode(snapMode: SnapMode): void Static | Deprecated | |
setActiveIModelId(iModelId: string): void Static | Deprecated | |
setActiveSelectionScope(selectionScopeId: string): void Static | This method stores the active selection scope to the supplied scope id, and triggers | Deprecated |
setAnimateToolSettings(value: boolean): void Static | Deprecated | |
setAutoCollapseUnpinnedPanels(value: boolean): void Static | Method used to enable the automatic closing of an unpinned widget panel as soon as the | Deprecated |
setColorTheme(theme: ThemeId): void Static | Set the theme value used by the ThemeManager component. | Deprecated |
setDefaultIModelViewportControlId(iModelViewportControlId: string, immediateSync: booleanfalse): void Static | Deprecated | |
setDefaultViewId(viewId: string, immediateSync: booleanfalse): void Static | Deprecated | |
setDefaultViewState(viewState: ViewState, immediateSync: booleanfalse): void Static | ||
setHideIsolateEmphasizeActionHandler(handler: HideIsolateEmphasizeActionHandler): void Static | ||
setIModelConnection(iModelConnection: IModelConnection, immediateSync: booleanfalse): void Static | ||
setIsUiVisible(visible: boolean): void Static | Deprecated | |
setNumItemsSelected(numSelected: number): void Static | ||
setShowWidgetIcon(value: boolean): void Static | Deprecated | |
setToolbarOpacity(opacity: number): void Static | UiFramework.setToolbarOpacity() sets the non-hovered opacity to the value specified. | Deprecated |
setUiStateStorage(storage: UiStateStorage, immediateSync: booleanfalse): Promise<void> Static | ||
setUseDragInteraction(useDragInteraction: boolean): void Static | Deprecated | |
setUseToolAsToolSettingsLabel(value: boolean): void Static | Deprecated | |
setViewOverlayDisplay(display: boolean): void Static | Set the variable that controls display of the view overlay. | Deprecated |
setWidgetOpacity(opacity: number): void Static | Deprecated | |
showAngleEditor(initialValue: number, location: Readonly<WritableXAndY>, onCommit: (value: number) => void, onCancel: () => void, anchorElement?: HTMLElement): boolean Static | Show an input editor for an angle value at a particular location. | |
showCalculator(initialValue: number, resultIcon: string, location: Readonly<WritableXAndY>, onOk: (value: number) => void, onCancel: () => void, anchorElement?: HTMLElement): boolean Static | Show a calculator at a particular location. | |
showComponent(...params: OptionalShowComponentParams): boolean Static | Show a React Element at a particular location. | |
showDimensionEditor(dimension: "length" | "height", initialValue: number, location: Readonly<WritableXAndY>, onCommit: (value: number) => void, onCancel: () => void, anchorElement?: HTMLElement): boolean Static | Show an input editor for a length value at a particular location. | |
showKeyinPalette(keyinEntries: KeyinEntry[], htmlElement?: HTMLElement): boolean Static | Show the Key-in Palette to display key-in from all registered Tools. | |
showMenuButton(id: string, menuItemsProps: CursorMenuItemProps[], location: Readonly<WritableXAndY>, anchorElement?: HTMLElement): boolean Static | Show a menu button at a particular location. | |
showToolbar(toolbarProps: ToolbarProps, location: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onItemExecuted: (item: any) => void, onCancel: () => void, placement: Placement"top-end", anchorElement?: HTMLElement): boolean Static | Show a Toolbar at a particular location. | |
terminate(): void Static | Un-registers the UiFramework internationalization service namespace. |
Properties
Name | Type | Description | |
---|---|---|---|
animateToolSettings Accessor Static ReadOnly | boolean | Animate Tool Settings on appear. | |
autoCollapseUnpinnedPanels Accessor Static ReadOnly | boolean | When true , panels will close as soon as the mouse leave the panel. |
|
backstage Accessor Static ReadOnly | FrameworkBackstage | Operation on the backstage component. | |
childWindows Accessor Static ReadOnly | FrameworkChildWindows | Manage access to the child windows. | |
content Accessor Static ReadOnly | FrameworkContent | Manage content presented by the frontstages. | |
controls Accessor Static ReadOnly | FrameworkControls | Manage registered controls. | |
dialogs Accessor Static ReadOnly | FrameworkDialogs | Manage displayed dialogs. | |
frameworkState Accessor Static ReadOnly | undefined | FrameworkState | The UiFramework state maintained by Redux. | |
frameworkStateKey Accessor Static ReadOnly | string | Key used to access framework state from redux store. | |
frontstages Accessor Static ReadOnly | FrameworkFrontstages | Manage access to frontstages and related helper methods. | |
hideIsolateEmphasizeActionHandler Accessor Static ReadOnly | HideIsolateEmphasizeActionHandler | ||
initialized Accessor Static ReadOnly | boolean | Determines if UiFramework has been initialized | |
keyboardShortcuts Accessor Static ReadOnly | FrameworkKeyboardShortcuts | Manages global keyboard shortcuts | |
localizationNamespace Accessor Static ReadOnly | string | The internationalization service namespace. | |
onIModelConnectionChanged Static Readonly | BeUiEvent<undefined | IModelConnection> | Event raised within UiFramework.setIModelConnection | |
onUiVisibilityChanged Static Readonly | UiVisibilityChangedEvent | Get Show Ui event. | |
settingsManager Accessor Static ReadOnly | SettingsManager | Property that returns the SettingManager used by AppUI-based applications. | |
showWidgetIcon Accessor Static ReadOnly | boolean | ||
store Accessor Static ReadOnly | Store<any, AnyAction> | The Redux store. | |
toolSettings Accessor Static ReadOnly | FrameworkToolSettings | Manage access and behavior of the tool settings. | |
useDefaultPopoutUrl Static | boolean | ||
useDragInteraction Accessor Static ReadOnly | boolean | ||
useToolAsToolSettingsLabel Accessor Static ReadOnly | boolean | Use Tool Name As Tool Settings Widget Tab Label. | |
viewOverlayDisplay Accessor Static ReadOnly | boolean | Returns the variable controlling whether the overlay is displayed in a Viewport. | |
visibility Accessor Static ReadOnly | FrameworkVisibility | Manages UI visibility (Show/Hide). |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.