FrameworkContent Interface
content interface
Methods
Name | Description | |
---|---|---|
addFloatingContentControl(contentControl?: ContentControl): void | Deprecated | |
contentSupportsCamera(content: ContentControl): boolean | Determines if viewport supports use of a camera. | Deprecated |
dropFloatingContentControl(contentControl?: ContentControl): void | Deprecated | |
getActive(): React.ReactNode | Gets the active content as a React.ReactNode. | Deprecated |
getActiveContentControl(): undefined | ContentControl | Return the active ContentControl. | Deprecated |
getActiveId(): undefined | string | Gets the active content id. | |
isContent3dView(content: ContentControl): boolean | Determines if content displays a 3d view. | Deprecated |
isContentDrawingView(content: ContentControl): boolean | Determines if content displays a Drawing view. | Deprecated |
isContentOrthographicView(content: ContentControl): boolean | Determines if content displays a Orthographic view. | Deprecated |
isContentSheetView(content: ContentControl): boolean | Determines if content displays a Sheet view. | Deprecated |
isContentSpatialView(content: ContentControl): boolean | Determines if content displays a Spatial view. | Deprecated |
refreshActive(activeContent: React.ReactNode): void | Refreshes the active ContentControl. | Deprecated |
setActive(activeContent?: React.ReactNode, forceEventProcessing?: boolean): void | Sets the active ContentControl. | Deprecated |
setActiveId(contentId?: string): void | Sets the active content. | |
setMouseDown(mouseDown: boolean): void | Sets the mouse down status for a content view |
Properties
Name | Type | Description | |
---|---|---|---|
dialogs Readonly | FrameworkStackedDialog<ContentDialogInfo> & { onContentDialogChangedEvent: ContentDialogChangedEvent } | Manage dialogs displaying managed content. | Deprecated |
isMouseDown Readonly | boolean | Determines if the mouse is down in a content view | |
layouts Readonly | { activeContentGroup: undefined | ContentGroup, activeLayout: undefined | ContentLayoutDef, add: , find: , getForGroup: , getKey: , refreshActive: , setActive: , setActiveContentGroup: } | Manage content layouts. | |
onActiveContentChangedEvent Readonly | ActiveContentChangedEvent | Gets the ActiveContentChangedEvent | |
onAvailableContentChangedEvent Readonly | UiEvent<{ contentId: string }> | Fires when floating contents are added or removed | |
onMouseDownChangedEvent Readonly | MouseDownChangedEvent | Gets the MouseDownChangedEvent |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.