FrameworkStackedDialog<DialogInfoType> Interface

FrameworkDialog that manages the top most content.

Extends

Methods

Name Description
getInfo(id: string): undefined | DialogInfoType    
getZIndex(id: string): number Get the z-index for a modeless dialog  
handlePointerDownEvent(_event: React.PointerEvent<Element>, id: string, updateFunc: () => void): void Handle a pointer down event on a modeless dialog  

Inherited methods

Name Inherited from Description
close(dialog?: React.ReactNode): void Inherited FrameworkDialog Close a modal dialog
open(dialog: React.ReactNode, id?: string, parentDocument?: Document): void Inherited FrameworkDialog Open a modal dialog
update(): void Inherited FrameworkDialog Update the dialogs

Inherited properties

Name Type Inherited from Description
active Readonly Inherited React.ReactNode FrameworkDialog Get the active modal dialog
count Readonly Inherited number FrameworkDialog Get the count of modal dialogs
dialogs Readonly Inherited DialogInfo[] FrameworkDialog Get the array of modal dialogs

Defined in

Last Updated: 30 January, 2025