ThemeManager Function

ThemeManager handles setting color themes. Note that this component will affect the entire application by setting the internal data-theme attribute. Component children are wrapped with v2 and v3 iTwinUI ThemeProvider components, so all nodes within the tree will have the same theme, and should be using iTwinUI 2.x or later. Specified ThemeId will be mapped to iTwinUI theme accordingly. Any other string will only apply the data-theme attribute to the underlying html element and ThemeProvider theme will be set to inherit, in this case the application is responsible for setting the theme, i.e. by using iTwinUI css variables.

This component should wrap ConfigurableUiContent.

<ThemeManager>
  <ConfigurableUiContent />
</ThemeManager>

ThemeManager(__namedParameters: ThemeManagerProps): React.JSX.Element

Parameter Type Description
__namedParameters ThemeManagerProps  

Returns - React.JSX.Element

Defined in

Last Updated: 20 November, 2024