FrameworkBackstage Interface
backstage interface.
Methods
Name | Description | |
---|---|---|
close(): void | Hides the backstage. | |
getBackstageToggleCommand(overrideIconSpec?: IconSpec): CommandItemDef | Creates a CommandItemDef that toggles the backstage. | Deprecated |
open(): void | Display the backstage. | |
toggle(): void | Toggle the backstage. |
Properties
Name | Type | Description | |
---|---|---|---|
isOpen Readonly | boolean | State of the backstage. | |
onToggled Readonly | BeEvent<(args: BackstageToggledArgs) => void> | Event activated when the backstage is toggled. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.