ToolItemDef Class

Deprecated  in 4.15.0. Use createForTool instead.

An Item that starts the execution of a Tool.

Extends

Methods

Name Description
constructor(toolItemProps: ToolItemProps, onItemExecuted?: OnItemExecutedFunc): ToolItemDef    
getItemDefForTool(tool: , icon?: string, ...args: any[]): ToolItemDef Static Create a ToolItemDef that will run a registered tool. Deprecated  

Inherited methods

Name Inherited from Description
execute(): void Inherited ActionButtonItemDef Called when the action button is invoked by a click or touch
getDimension(orientation: Orientation): number Inherited ActionButtonItemDef Determines the dimension in a given orientation
handleSizeKnown(size: SizeProps): void Inherited ActionButtonItemDef Called when the size of the action button is initialized and the size is known
setDescription(v: string | StringGetter | ConditionalStringValue): void Inherited ActionButtonItemDef Set the description.
setLabel(v: string | StringGetter | ConditionalStringValue): void Inherited ActionButtonItemDef Set the label.
setTooltip(v: string | StringGetter | ConditionalStringValue): void Inherited ActionButtonItemDef Set the tooltip.
initializeDef(me: ItemDefBase, itemProps: ItemProps): void Static Inherited ActionButtonItemDef  

Properties

Name Type Description
id Accessor ReadOnly string    
toolId string    

Inherited properties

Name Type Inherited from Description
_commandHandler Protected Inherited CommandHandler | undefined ActionButtonItemDef Command Handler for the action button
applicationData Inherited any | undefined ActionButtonItemDef  
badgeKind Inherited BadgeKind | undefined ActionButtonItemDef  
badgeType Inherited BadgeType | undefined ActionButtonItemDef  
defaultButtonSize Static Inherited number ActionButtonItemDef The default button size for all action buttons
description Accessor Inherited ReadOnly string ActionButtonItemDef Get the description string
iconElement Inherited React.ReactNode | undefined ActionButtonItemDef  
iconSpec Inherited IconSpec | undefined ActionButtonItemDef  
isActive Accessor Inherited boolean ActionButtonItemDef  
isDisabled Inherited boolean | ConditionalBooleanValue ActionButtonItemDef  
isHidden Inherited boolean | ConditionalBooleanValue ActionButtonItemDef  
isPressed Inherited boolean ActionButtonItemDef  
label Accessor Inherited ReadOnly string ActionButtonItemDef Get the label string
parameters Inherited any | undefined ActionButtonItemDef Parameters passed to the Command Handler
rawLabel Accessor Inherited ReadOnly string | StringGetter | ConditionalStringValue ActionButtonItemDef Get the label string
size Inherited SizeProps | undefined ActionButtonItemDef Size of the action button, as set by handleSizeKnown
tooltip Accessor Inherited ReadOnly string ActionButtonItemDef Get the tooltip string
trayId Accessor Inherited ReadOnly undefined ActionButtonItemDef  

Defined in

Last Updated: 30 January, 2025