ItemDefBase Class
Deprecated in 4.15.0. Use specific item types instead, i.e. ToolbarItem.
The base class for Items.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(itemProps: ItemProps): ItemDefBase | ||
setDescription(v: string | StringGetter | ConditionalStringValue): void | Set the description. | |
setLabel(v: string | StringGetter | ConditionalStringValue): void | Set the label. | |
setTooltip(v: string | StringGetter | ConditionalStringValue): void | Set the tooltip. | |
initializeDef(me: ItemDefBase, itemProps: ItemProps): void Static |
Properties
Name | Type | Description | |
---|---|---|---|
applicationData | any | undefined | ||
badgeKind | BadgeKind | undefined | ||
badgeType | BadgeType | undefined | Deprecated | |
description Accessor ReadOnly | string | Get the description string | |
iconElement | React.ReactNode | undefined | ||
iconSpec | IconSpec | undefined | ||
id Accessor Abstract ReadOnly | string | ||
isActive Accessor | boolean | ||
isDisabled | boolean | ConditionalBooleanValue | ||
isHidden | boolean | ConditionalBooleanValue | ||
isPressed | boolean | ||
label Accessor ReadOnly | string | Get the label string | |
rawLabel Accessor ReadOnly | string | StringGetter | ConditionalStringValue | Get the label string | |
tooltip Accessor ReadOnly | string | Get the tooltip string | |
trayId Accessor ReadOnly | undefined |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.