ItemProps Interface
Deprecated in 4.15.0. Use specific item types instead, i.e. ToolbarActionItem.
Definition that specifies properties shared between many ConfigurableUi components.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
applicationData | any | undefined | can be used by application to store miscellaneous data. | |
badgeKind | BadgeKind | undefined | Specifies the kind of badge, if any, to be overlaid on the item. | |
badgeType | BadgeType | undefined | Badge to be overlaid on the item. | Deprecated |
description | string | StringGetter | ConditionalStringValue | if set, it is used to explicitly set the description shown by a component. | |
descriptionKey | string | undefined | if set, it is used to define a key that is used to look up a localized string. | |
icon | IconSpec | undefined | abstract icon definition, used when create itemDef from abstract item (ie. | |
isActive | boolean | undefined | if set, component will be considered "active" an will display an "active stripe" - defaults to false | |
isDisabled | boolean | ConditionalBooleanValue | if true component will be disabled - defaults to false | |
isHidden | boolean | ConditionalBooleanValue | if true component will be hidden - defaults to false | |
isPressed | boolean | undefined | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. | |
label | string | StringGetter | ConditionalStringValue | if set, it is used to explicitly set the label shown by a component. | |
labelKey | string | undefined | if set, it is used to define a key that is used to look up a localized string. | |
tooltip | string | StringGetter | ConditionalStringValue | used to explicitly set the tooltip shown by a component. | |
tooltipKey | string | undefined | if set, it is used to define a key that is used to look up a localized string. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | IconProps | Custom CSS class name |
iconSpec | IconSpec | undefined | IconProps | CSS class name or SvgPath for icon. |
itemId | string | undefined | IconProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | IconProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.