ToolItemProps Interface
Deprecated in 4.15.0. Use specific item types instead, i.e. ToolbarActionItem.
Properties for a Tool item with a tool id.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
toolId | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData Inherited | any | undefined | ItemProps | can be used by application to store miscellaneous data. |
badgeKind Inherited | BadgeKind | undefined | ItemProps | Specifies the kind of badge, if any, to be overlaid on the item. |
badgeType Inherited | BadgeType | undefined | ItemProps | Badge to be overlaid on the item. |
className Inherited | string | undefined | ItemProps | Custom CSS class name |
description Inherited | string | StringGetter | ConditionalStringValue | ItemProps | if set, it is used to explicitly set the description shown by a component. |
descriptionKey Inherited | string | undefined | ItemProps | if set, it is used to define a key that is used to look up a localized string. |
execute Inherited | (args?: any) => any | undefined | CommandHandler | Function to execute |
getCommandArgs Inherited | () => any[] | undefined | CommandHandler | Function to get the parameters passed to the function |
icon Inherited | IconSpec | undefined | ItemProps | abstract icon definition, used when create itemDef from abstract item (ie. |
iconSpec Inherited | IconSpec | undefined | ItemProps | CSS class name or SvgPath for icon. |
isActive Inherited | boolean | undefined | ItemProps | if set, component will be considered "active" an will display an "active stripe" - defaults to false |
isDisabled Inherited | boolean | ConditionalBooleanValue | ItemProps | if true component will be disabled - defaults to false |
isHidden Inherited | boolean | ConditionalBooleanValue | ItemProps | if true component will be hidden - defaults to false |
isPressed Inherited | boolean | undefined | ItemProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
itemId Inherited | string | undefined | ItemProps | Optional unique identifier for item. |
label Inherited | string | StringGetter | ConditionalStringValue | ItemProps | if set, it is used to explicitly set the label shown by a component. |
labelKey Inherited | string | undefined | ItemProps | if set, it is used to define a key that is used to look up a localized string. |
parameters Inherited | any | undefined | CommandHandler | Parameters passed to the function |
style Inherited | React.CSSProperties | undefined | ItemProps | Custom CSS style properties |
tooltip Inherited | string | StringGetter | ConditionalStringValue | ItemProps | used to explicitly set the tooltip shown by a component. |
tooltipKey Inherited | string | undefined | ItemProps | if set, it is used to define a key that is used to look up a localized string. |
Defined in
Last Updated: 30 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.