ToolAssistanceFieldProps Interface
Properties of ToolAssistanceField component.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
cursorPromptTimeout | number | Cursor Prompt Timeout period. | |
defaultPromptAtCursor | boolean | Indicates whether to show promptAtCursor by default. | |
fadeOutCursorPrompt | boolean | Fade Out the Cursor Prompt when closed. | |
includePromptAtCursor | boolean | Indicates whether to include promptAtCursor Checkbox. | |
uiStateStorage | UiStateStorage | undefined | Optional parameter for persistent UI settings. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.