ModalFrontstageProps Interface

Properties for the ModalFrontstage React component

Extends

Properties

Name Type Description
appBarRight React.ReactNode | undefined An optional React node displayed in the upper right of the modal Frontstage.  
backButton React.ReactNode | undefined If specified overrides the default back button.  
children React.ReactNode | undefined Content  
closeModal () => any Callback for closing the modal Frontstage.  
isOpen boolean | undefined Indicates whether the modal Frontstage is open  
navigateBack () => any | undefined Callback for navigating back from the modal Frontstage.  
title string Title displayed at the top of the modal Frontstage  

Inherited properties

Name Type Inherited from Description
className Inherited string | undefined CommonProps Custom CSS class name
itemId Inherited string | undefined CommonProps Optional unique identifier for item.
style Inherited React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 30 January, 2025