useUiItemsProviderToolbarItems Function
Deprecated in 4.4.0. This uses ToolbarItemsManager which is internal, directly use ToolbarComposer instead.
Hook that retrieves active frontstage toolbar items from UiItemsProviders and manage them through ToolbarItemsManager.
useUiItemsProviderToolbarItems(manager: , toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation): ReadonlyArray<ToolbarItem>
Parameter | Type | Description |
---|---|---|
manager | ||
toolbarUsage | ToolbarUsage | |
toolbarOrientation | ToolbarOrientation |
Returns - ReadonlyArray<ToolbarItem>
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.