FrameworkToolAdmin Class
Subclass of ToolAdmin
in @itwin/core-frontend
to be used to initialize IModelApp
.
Enable processing of shortcut keys registered to keyboardShortcuts when focus is set to Home.
await IModelApp.startup({
toolAdmin: new FrameworkToolAdmin()
});
Extends
Methods
Name | Description | |
---|---|---|
constructor(): FrameworkToolAdmin | ||
processShortcutKey(e: KeyboardEvent, wentDown: boolean): Promise<boolean> |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.