ToolbarGroupItem Interface

Describes the data needed to insert a group button into a toolbar.

Extends

Properties

Name Type Description
icon Readonly IconSpec Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. Deprecated  
items Readonly ReadonlyArray<ToolbarActionItem | ToolbarGroupItem> children of the group  
label Readonly string | ConditionalStringValue label, shown as tool tip on group button or a group button label in a group panel.  
panelLabel Readonly string | ConditionalStringValue label shown as the title in at top of group panel.  
parentGroupItemId Readonly string | undefined Optional parent tool group to add the tool to.  

Inherited properties

Name Type Inherited from Description
badge Readonly Inherited BadgeType | undefined CommonToolbarItem Describes badge.
badgeKind Readonly Inherited BadgeKind | undefined CommonToolbarItem Specifies the kind of badge, if any, to be rendered.
description Readonly Inherited string | ConditionalStringValue CommonToolbarItem Optional description
groupPriority Readonly Inherited number | undefined CommonToolbarItem Specifies the item's grouping value.
iconNode Readonly Inherited React.ReactNode | undefined CommonToolbarItem Icon of a toolbar item.
id Readonly Inherited string CommonToolbarItem Require uniqueId for the item.
isActive Readonly Inherited boolean | undefined CommonToolbarItem Defines if the item is active (shown with an active stripe/bar).
isDisabled Readonly Inherited boolean | ConditionalBooleanValue CommonToolbarItem Describes if the item is enabled or disabled.
isHidden Readonly Inherited boolean | ConditionalBooleanValue CommonToolbarItem Describes if the item is visible or hidden.
itemPriority Readonly Inherited number CommonToolbarItem Priority within a toolbar or group.
layouts Readonly Inherited ToolbarItemLayouts | undefined CommonToolbarItem Describes layout specific configuration of a toolbar item.

Defined in

Last Updated: 30 January, 2025