SheetNavigationAidControl Class

Deprecated  in 4.16.0. Use SheetNavigationAid component instead.

A Sheet Navigation Aid control.

Extends

Methods

Name Description
constructor(info: ConfigurableCreateInfo, options: any): SheetNavigationAidControl    
getSize(): undefined | string Square size of navigation aid.  

Inherited methods

Name Inherited from Description
getType(): ConfigurableUiControlType Inherited NavigationAidControl Get the type of this control.
onFrontstageDeactivated(): void Inherited NavigationAidControl Called when Frontstage is deactivated.
onFrontstageReady(): void Inherited NavigationAidControl Called when Frontstage is ready.
onInitialize(): void Inherited NavigationAidControl Called to initialize the ConfigurableUiControl.

Properties

Name Type Description
navigationAidId Static string    

Inherited properties

Name Type Inherited from Description
_appDataOptions Protected Inherited any NavigationAidControl  
applicationData Accessor Inherited ReadOnly any NavigationAidControl allow options set via appData to be seen by API calls
classId Accessor Inherited ReadOnly string NavigationAidControl Gets the class Id of configurable element
controlId Accessor Inherited ReadOnly string NavigationAidControl Returns the ID of this ConfigurableUiControl.
isReady Accessor Inherited ReadOnly Promise<void> NavigationAidControl Returns a promise that resolves when the control is ready for usage.
name Accessor Inherited ReadOnly string NavigationAidControl Get internal name of configurable element. If no name is defined in configuration
then the name will match the UniqueId.
reactNode Accessor Inherited React.ReactNode NavigationAidControl The React element associated with this control

Defined in

Last Updated: 30 January, 2025