ListPicker Class
List Picker that lets the user pick from a list of items to enable/disable It also provides options to enable all, disable all and invert selection
Extends
- React.Component<ListPickerPropsExtended>
Methods
Name | Description | |
---|---|---|
constructor(props: ListPickerPropsExtended): ListPicker | Creates a ListPicker | |
isSpecialItem(item: ListItem): boolean | Checks if item is a special item. | |
render(): React.JSX.Element | Renders ListPicker |
Properties
Name | Type | Description | |
---|---|---|---|
Key_All Accessor Static ReadOnly | number | ||
Key_Invert Accessor Static ReadOnly | number | ||
Key_None Accessor Static ReadOnly | number | ||
Key_Separator Accessor Static ReadOnly | number |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.