CommonBackstageItem Interface
Describes the data needed to insert a button into the backstage menu.
Properties
Name | Type | Description | |
---|---|---|---|
badge Readonly | BadgeType | undefined | Describes badge. | Deprecated |
badgeKind Readonly | BadgeKind | undefined | Specifies the kind of badge, if any, to be rendered. | |
groupPriority Readonly | number | Specifies the item's grouping value. | |
icon Readonly | IconSpec | undefined | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. | Deprecated |
iconNode Readonly | React.ReactNode | undefined | Icon of the backstage item. | |
id Readonly | string | Required unique id of the item. | |
isActive Readonly | boolean | ConditionalBooleanValue | Describes if the item is active. | |
isDisabled Readonly | boolean | ConditionalBooleanValue | Describes if the item is enabled or disabled. | |
isHidden Readonly | boolean | ConditionalBooleanValue | Describes if the item is visible or hidden. | |
itemPriority Readonly | number | Priority within a group (recommend using values 1 through 100). | |
label Readonly | string | ConditionalStringValue | Label. | |
subtitle Readonly | string | ConditionalStringValue | Subtitle. | |
tooltip Readonly | string | ConditionalStringValue | Tooltip. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.