AnalysisAnimationTimelineDataProvider Class
Analysis Timeline Data Provider - Allows a TimelineComponent to animate the AnalysisStyle information stored in a ViewState.
Extends
- BaseTimelineDataProvider
Methods
Name | Description | |
---|---|---|
constructor(viewState: ViewState, viewport?: ScreenViewport): AnalysisAnimationTimelineDataProvider | ||
loadTimelineData(): Promise<boolean> | ||
onAnimationFractionChanged(animationFraction: number): void | ||
onPlaybackSettingChanged(settings: PlaybackSettings): void |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getSettings(): PlaybackSettings Inherited | BaseTimelineDataProvider | |
updateSettings(settings: PlaybackSettings): void Inherited | BaseTimelineDataProvider | Called to save the playback settings |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_settings Protected Inherited | PlaybackSettings | BaseTimelineDataProvider | |
_viewport Protected Inherited | undefined | ScreenViewport | BaseTimelineDataProvider | |
animationFraction Inherited | number | BaseTimelineDataProvider | Current animation fraction from 0.0 to 1.0 |
duration Accessor Inherited ReadOnly | number | BaseTimelineDataProvider | Called to get playback duration |
end Inherited | undefined | Date | BaseTimelineDataProvider | End date for entire timeline |
id Readonly Inherited | "TestTimelineDataProvider" | BaseTimelineDataProvider | uniqueId of provider |
initialDuration Accessor Inherited ReadOnly | number | BaseTimelineDataProvider | Called to get the initial scrubber location |
loop Accessor Inherited ReadOnly | boolean | BaseTimelineDataProvider | If true the playback will continuously loop. |
start Inherited | undefined | Date | BaseTimelineDataProvider | Starting date for entire timeline |
supportsTimelineAnimation Inherited | boolean | BaseTimelineDataProvider | returns true if the provider has timeline animation data available |
viewId Inherited | string | BaseTimelineDataProvider | view id when viewport is initially assigned |
viewport Accessor Inherited | undefined | ScreenViewport | BaseTimelineDataProvider | viewport to show animation |
Defined in
Last Updated: 30 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.