ContentProps Interface
Properties for content displayed in a content view
Properties
Name | Type | Description | |
---|---|---|---|
applicationData | any | undefined | Optional application data passed down to the content view. | Deprecated |
classId | string | ConfigurableUiControlConstructor | The class name or ConfigurableUiControlConstructor of the content control. | Deprecated |
content | React.ReactNode | undefined | Content to be displayed in the content view. | |
id | string | A unique id for the Content View within the group. | |
renderActiveStrip | boolean | ConditionalValue<undefined | boolean> | Describes if the content should display the active strip. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.