StandardContentLayouts Class
Class that define Standard Content Layouts that can be used to specify how the content is arranged in a frontstage.
Methods
Name | Description | |
---|---|---|
constructor(): StandardContentLayouts |
Properties
Name | Type | Description | |
---|---|---|---|
availableLayouts Static Readonly | ContentLayoutProps[] | ||
fourQuadrants Static Readonly | ContentLayoutProps | ||
singleView Static Readonly | ContentLayoutProps | ||
threeViewsTwoOnBottom Static Readonly | ContentLayoutProps | ||
threeViewsTwoOnLeft Static Readonly | ContentLayoutProps | ||
threeViewsTwoOnRight Static Readonly | ContentLayoutProps | ||
threeViewsTwoOnTop Static Readonly | ContentLayoutProps | ||
twoHorizontalSplit Static Readonly | ContentLayoutProps | ||
twoVerticalSplit Static Readonly | ContentLayoutProps |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.