AccuDrawUiSettings Interface
AccuDraw User Interface Settings
Properties
Name | Type | Description | |
---|---|---|---|
angleBackgroundColor | string | ColorDef | Angle field background color | |
angleForegroundColor | string | ColorDef | Angle field foreground color | |
angleIcon | IconSpec | undefined | Angle field icon. | Deprecated |
angleIconNode | React.ReactNode | undefined | Angle field icon. | |
angleLabel | string | undefined | Angle field label | |
angleStyle | React.CSSProperties | undefined | Angle field style | |
distanceBackgroundColor | string | ColorDef | Distance field background color | |
distanceForegroundColor | string | ColorDef | Distance field foreground color | |
distanceIcon | IconSpec | undefined | Distance field icon. | Deprecated |
distanceIconNode | React.ReactNode | undefined | Distance field icon. | |
distanceLabel | string | undefined | Distance field label | |
distanceStyle | React.CSSProperties | undefined | Distance field style | |
xBackgroundColor | string | ColorDef | X field background color | |
xForegroundColor | string | ColorDef | X field foreground color | |
xIcon | IconSpec | undefined | X field icon. | Deprecated |
xIconNode | React.ReactNode | undefined | X field icon. | |
xLabel | string | undefined | X field label | |
xStyle | React.CSSProperties | undefined | X field style | |
yBackgroundColor | string | ColorDef | Y field background color | |
yForegroundColor | string | ColorDef | Y field foreground color | |
yIcon | IconSpec | undefined | Y field icon. | Deprecated |
yIconNode | React.ReactNode | undefined | Y field icon. | |
yLabel | string | undefined | Y field label | |
yStyle | React.CSSProperties | undefined | Y field style | |
zBackgroundColor | string | ColorDef | Z field background color | |
zForegroundColor | string | ColorDef | Z field foreground color | |
zIcon | IconSpec | undefined | Z field icon. | Deprecated |
zIconNode | React.ReactNode | undefined | Z field icon. | |
zLabel | string | undefined | Z field label | |
zStyle | React.CSSProperties | undefined | Z field style |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.