AppUiSettings Class
Deprecated in 4.15.0. Use ($@itwin/core-react#UiStateStorage$refLinkSource=appui-react/ui/appui-react/src/appui-react/uistate/AppUiSettings.ts@47) to persist UI settings.
These are the UI settings that are stored in the Redux store. They control the color theme, how toolbar group buttons work, and the opacity of floating widget when the cursor is not inside them. It is expect that an IModelApp using App UI components will create and register AppUiSettings with defaults specific to their application. This would be done by calling the following.
UiFramework.registerUserSettingsProvider(new AppUiSettings(defaults));
Implements
Methods
Name | Description | |
---|---|---|
constructor(defaults: Partial<InitialAppUiSettings>): AppUiSettings | ||
apply(storage: UiStateStorage): Promise<void> | ||
loadUserSettings(storage: UiStateStorage): Promise<void> | Function to load settings from settings storage |
Properties
Name | Type | Description | |
---|---|---|---|
animateToolSettings | UiStateEntry<boolean> | ||
autoCollapseUnpinnedPanels | UiStateEntry<boolean> | ||
colorTheme | UiStateEntry<ThemeId> | ||
dragInteraction | UiStateEntry<boolean> | ||
providerId Readonly | "AppUiSettingsProvider" | Unique provider Id | |
showWidgetIcon | UiStateEntry<boolean> | ||
toolbarOpacity | UiStateEntry<number> | ||
useToolAsToolSettingsLabel | UiStateEntry<boolean> | ||
widgetOpacity | UiStateEntry<number> |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.