AllowedUiItemsProviderOverrides Interface
UiItemsProvider overrides allows the application that registers a provider to limit when it is allowed to provide items
Properties
Name |
Type |
Description |
|
providerId |
string | undefined |
allows providerId to be overridden in the items manager for cases where the same provider needs to provide different content to different stages |
|
stageIds |
string[] | undefined |
if specified then the current stage's Id will be compared before allowing any items to be provided |
|
stageUsages |
string[] | undefined |
if specified then the current stage's Usage will be compared before allowing any items to be provided |
|
Defined in
Last Updated: 20 November, 2024