CustomItemProps Interface
Deprecated in 4.15.0. Use specific item types instead, i.e. ToolbarCustomItem.
Definition for a Custom item that renders a React component.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
customId | string | undefined | ||
popupPanelNode | React.ReactNode | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData | any | undefined | ItemProps | can be used by application to store miscellaneous data. |
badgeKind | BadgeKind | undefined | ItemProps | Specifies the kind of badge, if any, to be overlaid on the item. |
badgeType | BadgeType | undefined | ItemProps | Badge to be overlaid on the item. |
className | string | undefined | ItemProps | Custom CSS class name |
description | string | StringGetter | ConditionalStringValue | ItemProps | if set, it is used to explicitly set the description shown by a component. |
descriptionKey | string | undefined | ItemProps | if set, it is used to define a key that is used to look up a localized string. |
icon | IconSpec | undefined | ItemProps | abstract icon definition, used when create itemDef from abstract item (ie. |
iconSpec | IconSpec | undefined | ItemProps | CSS class name or SvgPath for icon. |
isActive | boolean | undefined | ItemProps | if set, component will be considered "active" an will display an "active stripe" - defaults to false |
isDisabled | boolean | ConditionalBooleanValue | ItemProps | if true component will be disabled - defaults to false |
isHidden | boolean | ConditionalBooleanValue | ItemProps | if true component will be hidden - defaults to false |
isPressed | boolean | undefined | ItemProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
itemId | string | undefined | ItemProps | Optional unique identifier for item. |
label | string | StringGetter | ConditionalStringValue | ItemProps | if set, it is used to explicitly set the label shown by a component. |
labelKey | string | undefined | ItemProps | if set, it is used to define a key that is used to look up a localized string. |
style | React.CSSProperties | undefined | ItemProps | Custom CSS style properties |
tooltip | string | StringGetter | ConditionalStringValue | ItemProps | used to explicitly set the tooltip shown by a component. |
tooltipKey | string | undefined | ItemProps | if set, it is used to define a key that is used to look up a localized string. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.