KeyboardShortcutMenu Class

Deprecated  in 4.15.0. Component used internally to display keyboard shortcuts in a context menu.

React component that displays a context menu at the cursor containing keyboard shortcuts.

Extends

Methods

Name Description
componentDidMount(): void Called immediately after a component is mounted.  
componentWillUnmount(): void Called immediately before a component is destroyed.  
render(): React.ReactNode    

Properties

Name Type Description
onKeyboardShortcutMenuEvent Static Readonly KeyboardShortcutMenuEvent Get KeyboardShortcut Menu Event.  
state Readonly KeyboardShortcutMenuState    

Defined in

Last Updated: 30 January, 2025