UiSettingsPage Function
Deprecated in 4.15.0. Use iTwinUI components to build a settings page.
UiSettingsPage displaying the active UI settings. This page lets users set the following settings.
- theme - Dark, Light, with or without High contrast, or based on OS preference.
- auto hide - Starts a timer and blanks out ui components that overlay content if there is no mouse movement for a period of time.
- drag interaction - If set, toolbar group buttons require a press and drag or a long press to open. In this mode a child action item is shown as the group button and is activated when button is clicked. If a different child item is selected, it becomes the active group button item.
- use proximity - Changes the opacity of toolbar from transparent to opaque as the mouse moves closer.
- snap widget opacity - triggers an abrupt change from transparent to opaque for tool and navigation widgets, instead of a gradual change based on mouse location.
- widget opacity - determines how transparent floating widgets become when the mouse in not in them.
UiSettingsPage(): React.JSX.Element
Returns - React.JSX.Element
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.