AccuDrawPopupManager Class
AccuDraw Popup Manager class
Methods
Name | Description | |
---|---|---|
constructor(): AccuDrawPopupManager | ||
hideCalculator(): boolean Static | ||
hideMenuButton(id: string): boolean Static | ||
showAngleEditor(el: HTMLElement, pt: Readonly<WritableXAndY>, value: number, onCommit: (value: number) => void, onCancel: () => void): boolean Static | ||
showCalculator(el: HTMLElement, pt: Readonly<WritableXAndY>, initialValue: number, resultIcon: string, onOk: (value: number) => void, onCancel: () => void): boolean Static | ||
showHeightEditor(el: HTMLElement, pt: Readonly<WritableXAndY>, value: number, onCommit: (value: number) => void, onCancel: () => void): boolean Static | ||
showLengthEditor(el: HTMLElement, pt: Readonly<WritableXAndY>, value: number, onCommit: (value: number) => void, onCancel: () => void): boolean Static | ||
showMenuButton(id: string, el: HTMLElement, pt: Readonly<WritableXAndY>, menuItemsProps: CursorMenuItemProps[]): boolean Static |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.