FloatingViewportContentControl Class
Deprecated in 4.16.0. Extends a deprecated class ViewportContentControl.
Extends
Methods
Name | Description | |
---|---|---|
constructor(uniqueId: string, name: string, node: React.ReactNode): FloatingViewportContentControl |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getKeyedReactNode(): React.ReactNode Protected Inherited | ViewportContentControl | |
getReactElementForViewSelectorChange(_iModel: IModelConnection, _viewDefinitionId: string, _viewState: ViewState, _name: string): React.ReactNode Inherited | ViewportContentControl | Get the React.Element for a ViewSelector change. |
getReactNode(): React.ReactNode Protected Inherited | ViewportContentControl | |
getType(): ConfigurableUiControlType Inherited | ViewportContentControl | Gets the type of ConfigurableUiControl, which is 'Viewport' in this case |
onActivated(): void Inherited | ViewportContentControl | Called when this ContentControl is activated |
onDeactivated(): void Inherited | ViewportContentControl | Called when this ContentControl is deactivated |
onFrontstageDeactivated(): void Inherited | ViewportContentControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void Inherited | ViewportContentControl | Called when Frontstage is ready. |
onInitialize(): void Inherited | ViewportContentControl | Called to initialize the ConfigurableUiControl. |
processViewSelectorChange(iModel: IModelConnection, viewDefinitionId: string, viewState: ViewState, name: string): Promise<void> Inherited | ViewportContentControl | Process a ViewSelector change. |
setIsReady(): void Inherited | ViewportContentControl | Returns a promise that resolves when the control is ready for usage. |
Properties
Name | Type | Description | |
---|---|---|---|
reactNode Accessor | React.ReactNode | The React node associated with this control. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected Inherited | any | ViewportContentControl | |
_reactNode Protected Inherited | React.ReactNode | ViewportContentControl | |
applicationData Accessor Inherited ReadOnly | any | ViewportContentControl | allow options set via appData to be seen by API calls |
classId Accessor Inherited ReadOnly | string | ViewportContentControl | Gets the class Id of configurable element |
controlId Accessor Inherited ReadOnly | string | ViewportContentControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor Inherited ReadOnly | Promise<void> | ViewportContentControl | Returns a promise that resolves when the control is ready for usage. |
isViewport Accessor Inherited ReadOnly | boolean | ViewportContentControl | Returns true if this control is a Viewport control. |
name Accessor Inherited ReadOnly | string | ViewportContentControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
navigationAidControl Accessor Inherited ReadOnly | string | ViewportContentControl | Get the NavigationAidControl associated with this ContentControl |
supportsViewSelectorChange Accessor Inherited ReadOnly | boolean | ViewportContentControl | Returns true if this control supports processing ViewSelector changes. |
viewport Accessor Inherited | undefined | ScreenViewport | ViewportContentControl | The underlying ScreenViewport |
Defined in
Last Updated: 30 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.