FrontstageConfig Interface
Deprecated in 4.15.0. Use Frontstage instead.
Configuration from which a frontstage is created.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
bottomPanel Readonly | StagePanelConfig | undefined | Bottom panel of the application. | |
contentGroup Readonly | ContentGroup | ContentGroupProvider | Content group of the frontstage that describes the content views. | |
contentManipulation Readonly | WidgetConfig | undefined | The top-left corner that shows tools typically used to query and modify content. | |
defaultTool Readonly | string | undefined | The defaultTool is is started when then frontstage loads and whenever any other tools exit. | |
id Readonly | string | Id of the frontstage. | |
leftPanel Readonly | StagePanelConfig | undefined | Left panel of the application. | |
rightPanel Readonly | StagePanelConfig | undefined | Right panel of the application. | |
statusBar Readonly | WidgetConfig | undefined | The status bar of the application. | |
toolSettings Readonly | WidgetConfig | undefined | The settings of the active tool. | |
topPanel Readonly | StagePanelConfig | undefined | Top panel of the application. | |
usage Readonly | string | undefined | Usage type for this Frontstage. | |
version Readonly | number | Frontstage version. | |
viewNavigation Readonly | WidgetConfig | undefined | The top-right corner that shows view navigation tools. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.