PropsHelper Class
Deprecated in 4.16.0. Used internally.
A set of helper methods for various props
Methods
Name | Description | |
---|---|---|
constructor(): PropsHelper | ||
getAbstractPropsForReactIcon(iconSpec: IconSpec, internalData?: Map<string, any>): Partial<AbstractWidgetProps> | Partial<CommonBackstageItem> Static | Deprecated | |
getIcon(iconSpec: ConditionalStringValue | React.ReactNode): undefined | React.ReactElement<any, string | React.JSXElementConstructor<any>> Static | Get JSX element that defines an icon. | |
getStringFromSpec(spec: string | StringGetter | ConditionalStringValue): string Static | Get the display string. | |
getStringSpec(explicitValue: string | StringGetter | ConditionalStringValue, stringKey?: string): string | StringGetter | ConditionalStringValue Static | Get spec for returning a string. | |
isShallowEqual(newObj: any, prevObj: any): boolean Static | returns true if the two objects are the same using a shallow compare of each property |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.