StateManager Class
Deprecated in 4.15.0. Use your preferred state management library instead.
Centralized state management class using Redux actions, reducers and store. This class monitors the ReducerRegistry and will automatically update the store when a new reducer is registered. This allows the store to be incrementally constructed as modules and/or extensions are loaded.
Methods
Name | Description | |
---|---|---|
constructor(defaultReducers?: NameToReducerMap): StateManager | StateManager construct. | |
isInitialized(suppressErrorLog: booleanfalse): boolean Static | Method to test if the StateManager has been initialized. |
Properties
Name | Type | Description | |
---|---|---|---|
state Accessor Static ReadOnly | any | Return the current state from the Redux store. | |
store Accessor Static ReadOnly | Store<any, AnyAction> | Return the current Redux store. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.