StandardMessageBoxProps Interface

Deprecated  in 4.15.0. Props of deprecated StandardMessageBox component.

Properties for StandardMessageBox React component

Extends

Properties

Name Type Description
children React.ReactNode | undefined Content.  
iconType MessageBoxIconType The standard icon to display in the message box.  
messageBoxType MessageBoxType Controls the button set displayed.  
onResult (result: MessageBoxValue) => void | undefined Callback function for processing the message box result.  
opened boolean Indicates whether the message box is open.  
title string Title to display in the message box.  

Inherited properties

Name Type Inherited from Description
className string | undefined CommonProps Custom CSS class name
itemId string | undefined CommonProps Optional unique identifier for item.
style React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 20 November, 2024