StatusBarLabelItem Interface

Describes the data needed to insert a label item with an optional icon into the status bar.

Extends

Properties

Name Type Description
icon Readonly IconSpec | undefined Icon of a status bar item. Deprecated  
iconNode Readonly React.ReactNode | undefined Icon of a status bar item.  
label Readonly string | ConditionalStringValue Label.  
labelSide Readonly StatusBarLabelSide | undefined Defines which side of icon to display label if icon is defined.  

Inherited properties

Name Type Inherited from Description
badge Readonly Inherited BadgeType | undefined CommonStatusBarItem Describes badge.
badgeKind Readonly Inherited BadgeKind | undefined CommonStatusBarItem Specifies the kind of badge, if any, to be rendered.
id Readonly Inherited string CommonStatusBarItem Required unique id of the item.
isDisabled Readonly Inherited boolean | ConditionalBooleanValue CommonStatusBarItem Describes if the item is enabled or disabled.
isHidden Readonly Inherited boolean | ConditionalBooleanValue CommonStatusBarItem Describes if the item is visible or hidden.
itemPriority Readonly Inherited number CommonStatusBarItem Priority within a section (recommend using values 1 through 100).
section Readonly Inherited StatusBarSection CommonStatusBarItem status bar section

Defined in

Last Updated: 30 January, 2025