IModelConnectedViewport Function
Deprecated in 4.15.0. Use ($@itwin/imodel-components-react#ViewportComponent$refLinkSource=appui-react/ui/appui-react/src/appui-react/content/IModelViewport.tsx@39) instead.
Viewport that is connected to the IModelConnection property in the Redux store. The application must set up the Redux store and include the FrameworkReducer.
IModelConnectedViewport(props: Omit<ViewportProps, "viewState" | "imodel">): "null" | React.JSX.Element
@note Requires redux provider.
Parameter | Type | Description |
---|---|---|
props | Omit<ViewportProps, "viewState" | "imodel"> |
Returns - "null" | React.JSX.Element
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.