ViewportProps Interface
Properties for ViewportComponent component.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
imodel | IModelConnection | IModel to display | |
viewDefinitionId | string | undefined | Id of a default view definition to load as a starting point | |
viewportRef | (v: ScreenViewport) => void | undefined | Function to get a reference to the ScreenViewport | |
viewState | ViewStateProp | undefined | ViewState to use as a starting point |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className Inherited | string | undefined | CommonProps | Custom CSS class name |
itemId Inherited | string | undefined | CommonProps | Optional unique identifier for item. |
style Inherited | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 30 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.