BackstageActionItem Interface
Describes the data needed to insert an action button into the backstage menu.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
execute Readonly | () => void |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
badge Readonly | BadgeType | undefined | CommonBackstageItem | Describes badge. |
badgeKind Readonly | BadgeKind | undefined | CommonBackstageItem | Specifies the kind of badge, if any, to be rendered. |
groupPriority Readonly | number | CommonBackstageItem | Specifies the item's grouping value. |
icon Readonly | IconSpec | undefined | CommonBackstageItem | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
iconNode Readonly | React.ReactNode | undefined | CommonBackstageItem | Icon of the backstage item. |
id Readonly | string | CommonBackstageItem | Required unique id of the item. |
isActive Readonly | boolean | ConditionalBooleanValue | CommonBackstageItem | Describes if the item is active. |
isDisabled Readonly | boolean | ConditionalBooleanValue | CommonBackstageItem | Describes if the item is enabled or disabled. |
isHidden Readonly | boolean | ConditionalBooleanValue | CommonBackstageItem | Describes if the item is visible or hidden. |
itemPriority Readonly | number | CommonBackstageItem | Priority within a group (recommend using values 1 through 100). |
label Readonly | string | ConditionalStringValue | CommonBackstageItem | Label. |
subtitle Readonly | string | ConditionalStringValue | CommonBackstageItem | Subtitle. |
tooltip Readonly | string | ConditionalStringValue | CommonBackstageItem | Tooltip. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.