StatusBarCustomItem Interface
Describes the data needed to insert an item into the StatusBar.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
content Readonly | React.ReactNode | Content of the StatusBar item. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
badge Readonly | BadgeType | undefined | CommonStatusBarItem | Describes badge. |
badgeKind Readonly | BadgeKind | undefined | CommonStatusBarItem | Specifies the kind of badge, if any, to be rendered. |
id Readonly | string | CommonStatusBarItem | Required unique id of the item. |
isDisabled Readonly | boolean | ConditionalBooleanValue | CommonStatusBarItem | Describes if the item is enabled or disabled. |
isHidden Readonly | boolean | ConditionalBooleanValue | CommonStatusBarItem | Describes if the item is visible or hidden. |
itemPriority Readonly | number | CommonStatusBarItem | Priority within a section (recommend using values 1 through 100). |
section Readonly | StatusBarSection | CommonStatusBarItem | status bar section |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.