CursorInformation Class
Cursor Information class
Methods
Name | Description | |
---|---|---|
constructor(): CursorInformation | ||
getRelativePositionFromCursorDirection(cursorDirection: CursorDirection): RelativePosition Static | Gets the relative position based on the cursor direction. | |
handleMouseMove(point: Readonly<WritableXAndY>): void Static | Handles the mouse movement. |
Properties
Name | Type | Description | |
---|---|---|---|
cursorDirection Accessor Static ReadOnly | CursorDirection | Gets the general cursor movement direction. | |
cursorPosition Accessor Static | Readonly<WritableXAndY> | The cursor position. | |
cursorX Accessor Static ReadOnly | number | Gets the cursor X position. | |
cursorY Accessor Static ReadOnly | number | Gets the cursor Y position. | |
onCursorUpdatedEvent Static Readonly | CursorUpdatedEvent | Gets the CursorUpdatedEvent. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.