ToolUiProvider Class

Deprecated  in 4.16.0. Extends a deprecated class ConfigurableUiControl.

ToolUiProvider provides the Tool Settings and/or Tool Assistance UI for a tool. The ToolUiProvider is registered for the tool id via UiFramework.controls.register.

Extends

Methods

Name Description
constructor(info: ConfigurableCreateInfo, options: any): ToolUiProvider    
getType(): ConfigurableUiControlType Gets the type of ConfigurableUiControl, which is 'ToolUiProvider' in this case  
reloadPropertiesFromTool(): void    
syncToolSettingsProperties(_args: SyncToolSettingsPropertiesEventArgs): void    

Inherited methods

Name Inherited from Description
onFrontstageDeactivated(): void Inherited ConfigurableUiControl Called when Frontstage is deactivated.
onFrontstageReady(): void Inherited ConfigurableUiControl Called when Frontstage is ready.
onInitialize(): void Inherited ConfigurableUiControl Called to initialize the ConfigurableUiControl.

Properties

Name Type Description
_dataProvider Protected undefined | UiDataProvider    
dataProvider Accessor undefined | UiDataProvider The UiDataProvider class  
horizontalToolSettingNodes Accessor undefined | ToolSettingsEntry[] An array of entries to load into the horizontal tool settings  
toolSettingsNode Accessor React.ReactNode A React node that holds tool settings when shown in a rectangular area (i.e.  

Inherited properties

Name Type Inherited from Description
_appDataOptions Protected Inherited any ConfigurableUiControl  
applicationData Accessor Inherited ReadOnly any ConfigurableUiControl allow options set via appData to be seen by API calls
classId Accessor Inherited ReadOnly string ConfigurableUiControl Gets the class Id of configurable element
controlId Accessor Inherited ReadOnly string ConfigurableUiControl Returns the ID of this ConfigurableUiControl.
isReady Accessor Inherited ReadOnly Promise<void> ConfigurableUiControl Returns a promise that resolves when the control is ready for usage.
name Accessor Inherited ReadOnly string ConfigurableUiControl Get internal name of configurable element. If no name is defined in configuration
then the name will match the UniqueId.

Defined in

Last Updated: 30 January, 2025