SupportsViewSelectorChange Interface

Deprecated  in 4.16.0. Implemented by classes derived from a deprecated ContentControl.

Interface to be implemented when the ContentControl supports ViewSelector changes

Implemented by

Methods

Name Description
processViewSelectorChange(iModel: IModelConnection, viewDefinitionId: string, viewState: ViewState, name: string): Promise<void> Process a ViewSelector change.  

Properties

Name Type Description
supportsViewSelectorChange boolean Returns true if this control supports reacting to ViewSelector changes.  

Defined in

Last Updated: 20 November, 2024