BackstageStageLauncher Interface
Describes the data needed to insert an action button into the backstage menu.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
stageId Readonly | string | Id of a frontstage that this item activates. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
badge Readonly Inherited | BadgeType | undefined | CommonBackstageItem | Describes badge. |
badgeKind Readonly Inherited | BadgeKind | undefined | CommonBackstageItem | Specifies the kind of badge, if any, to be rendered. |
groupPriority Readonly Inherited | number | CommonBackstageItem | Specifies the item's grouping value. |
icon Readonly Inherited | IconSpec | undefined | CommonBackstageItem | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
iconNode Readonly Inherited | React.ReactNode | undefined | CommonBackstageItem | Icon of the backstage item. |
id Readonly Inherited | string | CommonBackstageItem | Required unique id of the item. |
isActive Readonly Inherited | boolean | ConditionalBooleanValue | CommonBackstageItem | Describes if the item is active. |
isDisabled Readonly Inherited | boolean | ConditionalBooleanValue | CommonBackstageItem | Describes if the item is enabled or disabled. |
isHidden Readonly Inherited | boolean | ConditionalBooleanValue | CommonBackstageItem | Describes if the item is visible or hidden. |
itemPriority Readonly Inherited | number | CommonBackstageItem | Priority within a group (recommend using values 1 through 100). |
label Readonly Inherited | string | ConditionalStringValue | CommonBackstageItem | Label. |
subtitle Readonly Inherited | string | ConditionalStringValue | CommonBackstageItem | Subtitle. |
tooltip Readonly Inherited | string | ConditionalStringValue | CommonBackstageItem | Tooltip. |
Defined in
Last Updated: 30 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.