IRuleSet Interface

Interface used to represent logical collection of IRule instances.

Properties

Name Type Description
classRules IRule<AnyClass, object>[] | undefined The rules that apply to ECClass objects.  
constantRules IRule<Constant, object>[] | undefined The rules that apply to Constant objects.  
customAttributeClassRules IRule<CustomAttributeClass, object>[] | undefined The rules that apply to CustomAttributeClass objects.  
customAttributeContainerRules IRule<CustomAttributeContainerProps, object>[] | undefined The rules that apply to CustomAttributeContainerProps objects.  
customAttributeInstanceRules BaseRule<CustomAttributeContainerProps, CustomAttribute>[] | undefined The rules that apply to CustomAttribute objects.  
entityClassRules IRule<EntityClass, object>[] | undefined The rules that apply to EntityClass objects.  
enumerationRules IRule<Enumeration, object>[] | undefined The rules that apply to Enumeration objects.  
formatRules IRule<Format, object>[] | undefined The rules that apply to Format objects.  
invertedUnitRules IRule<InvertedUnit, object>[] | undefined The rules that apply to InvertedUnit objects.  
kindOfQuantityRules IRule<KindOfQuantity, object>[] | undefined The rules that apply to KindOfQuantity objects.  
mixinRules IRule<Mixin, object>[] | undefined The rules that apply to Mixin objects.  
name string The name of the rule set.  
phenomenonRules IRule<Phenomenon, object>[] | undefined The rules that apply to Phenomenon objects.  
propertyCategoryRules IRule<PropertyCategory, object>[] | undefined The rules that apply to PropertyCategory objects.  
propertyRules IRule<AnyProperty, object>[] | undefined The rules that apply to Property objects.  
relationshipConstraintRules IRule<RelationshipConstraint, object>[] | undefined The rules that apply to RelationshipConstraint objects.  
relationshipRules IRule<RelationshipClass, object>[] | undefined The rules that apply to RelationshipClass objects.  
schemaExclusionSet string[] | undefined A collection of schema names that should be excluded from adhering to the rules defined in this rule set.  
schemaItemRules IRule<SchemaItem, object>[] | undefined The rules that apply to SchemaItem objects.  
schemaRules IRule<Schema, object>[] | undefined The rules that apply to Schema objects.  
structClassRules IRule<StructClass, object>[] | undefined The rules that apply to StructClass objects.  
unitRules IRule<Unit, object>[] | undefined The rules that apply to Unit objects.  
unitSystemRules IRule<UnitSystem, object>[] | undefined The rules that apply to UnitSystem objects.  

Defined in

Last Updated: 21 November, 2024