Property Class
A common abstract class for all ECProperty types.
Extended by
Implements
Methods
Name | Description | |
---|---|---|
fromJSON(propertyProps: PropertyProps): Promise<void> | ||
fromJSONSync(propertyProps: PropertyProps): void | ||
getCategorySync(): undefined | PropertyCategory | ||
getCustomAttributes(): Promise<> | Retrieve all custom attributes in the current property and its base | |
getCustomAttributesSync(): | Retrieve all custom attributes in the current property and its base. | |
getKindOfQuantitySync(): undefined | KindOfQuantity | ||
isArray(): this is AnyArrayProperty | ||
isEnumeration(): this is AnyEnumerationProperty | ||
isNavigation(): this is NavigationProperty | ||
isPrimitive(): this is AnyPrimitiveProperty | ||
isStruct(): this is AnyStructProperty | ||
toJSON(): PropertyProps | Save this Property's properties to an object for serializing to JSON. |
Properties
Name | Type | Description | |
---|---|---|---|
category Accessor ReadOnly | undefined | LazyLoadedPropertyCategory | ||
class Accessor ReadOnly | AnyClass | ||
customAttributes Accessor ReadOnly | undefined | | ||
description Accessor ReadOnly | undefined | string | ||
fullName Accessor ReadOnly | string | Returns the name in the format 'ClassName.PropertyName'. | |
isReadOnly Accessor ReadOnly | boolean | ||
kindOfQuantity Accessor ReadOnly | undefined | LazyLoadedKindOfQuantity | ||
label Accessor ReadOnly | undefined | string | ||
name Accessor ReadOnly | string | ||
priority Accessor ReadOnly | number | ||
propertyType Accessor ReadOnly | PropertyType | ||
schema Accessor ReadOnly | Schema | Returns the schema of the class holding the property. |
Defined in
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.