RelationshipConstraint Class
A Typescript class representation of a ECRelationshipConstraint.
Implements
Methods
Name | Description | |
---|---|---|
fromJSON(relationshipConstraintProps: RelationshipConstraintProps): Promise<void> | ||
fromJSONSync(relationshipConstraintProps: RelationshipConstraintProps): void | ||
supportsClass(ecClass: ECClass): Promise<boolean> | Indicates if the provided ECClass is supported by this RelationshipConstraint. | |
toJSON(): RelationshipConstraintProps | Save this RelationshipConstraint's properties to an object for serializing to JSON. | |
classCompatibleWithConstraint(constraintClass: ECClass, testClass: ECClass, isPolymorphic: boolean): Promise<boolean> Static | Indicates if an ECClass is of the type or applies to the type (if a mixin) of the ECClass specified by the constraintClass parameter. |
Properties
Name | Type | Description | |
---|---|---|---|
abstractConstraint Accessor ReadOnly | undefined | LazyLoadedRelationshipConstraintClass | ||
constraintClasses Accessor ReadOnly | undefined | ReadonlyArray<LazyLoadedRelationshipConstraintClass> | ||
customAttributes Accessor ReadOnly | undefined | | ||
fullName Accessor ReadOnly | string | Returns the constraint name, ie. | |
isSource Accessor ReadOnly | boolean | True if this RelationshipConstraint is the Source relationship end. | |
multiplicity Accessor ReadOnly | RelationshipMultiplicity | ||
polymorphic Accessor ReadOnly | boolean | ||
relationshipClass Accessor ReadOnly | RelationshipClass | ||
relationshipEnd Accessor ReadOnly | RelationshipEnd | ||
roleLabel Accessor ReadOnly | undefined | string | ||
schema Accessor ReadOnly | Schema | Returns the schema of the RelationshipClass. |
Defined in
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.